第一周 數據結構與算法的關系
【主要考察:復雜度】
題1:最大子列和問題
給定K個整數組成的序列{ N1, N2, ..., NK },“連續子列”被定義為{ Ni, Ni+1, ..., Nj },其中 1 <= i <= j <= K。“最大子列和”則被定義為所有連續子列元素的和中最大者。例如給定序列{ -2, 11, -4, 13, -5, -2 },其連續子列{ 11, -4, 13 }有最大的和20。現要求你編寫程序,計算給定整數序列的最大子列和。
輸入格式:
輸入第1行給出正整數 K (<= 100000);第2行給出K個整數,其間以空格分隔。
輸出格式:
在一行中輸出最大子列和。如果序列中所有整數皆為負數,則輸出0。
輸入樣例:
6
-2 11 -4 13 -5 -2
輸出樣例:
20
解決思路:
- 暴力枚舉。O(N^3);
- 動態規劃。O(N);
算法優化的本質:減少重復計算,減少不必要的計算。
import java.util.Scanner;
public class MaxSubseqSum {
private static int getMaxSubSum(int[] list, int N)
{
int thisSum=0, maxSum=0;
for(int i = 0; i < N; i++)
{
thisSum += list[i];
if (thisSum > maxSum)
maxSum = thisSum;
else if (thisSum < 0)
thisSum = 0;
}
return maxSum;
}
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
while (in.hasNext())
{
int N = in.nextInt();
int i = 0;
int[] list = new int[N];
while (i < N)
list[i++] = in.nextInt();
int result = getMaxSubSum(list, N);
System.out.println(result);
}
}
}
題2:Maximum Subsequence Sum
Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
**Sample Input: **
10
-10 1 2 3 4 -5 -23 3 7 -21
**Sample Output: **
10 1 4
解決思路:
- 這道題比前面要求多了一條,不僅要返回最大子列和,還要告訴子序列首尾的index。關鍵在于什么時候修改首位的index,什么時候修改末位的index。
- 還要特別注意特殊輸入(0,負數,和為0等等)
import java.util.Scanner;
public class MaxSubseqSumV2 {
private static int[] getMaxSubSum(int[] list, int N)
{
int thisSum=0, maxSum=-1;
int tempIndex=0, leftIndex=0, rightIndex=0;
for(int i = 0; i < N; i++)
{
thisSum += list[i];
if (thisSum > maxSum)
{
maxSum = thisSum;
leftIndex = tempIndex;
rightIndex = i;
}
else if (thisSum < 0)
{
thisSum = 0;
tempIndex = i+1;
}
}
int[] result = new int[3];
result[1] = list[leftIndex];
if (maxSum == -1){
result[0] = 0;
result[2] = list[N-1];
}
else {
result[0] = maxSum;
result[2] = list[rightIndex];
}
return result;
}
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
while (in.hasNext())
{
int N = in.nextInt();
int i = 0;
int[] list = new int[N];
while (i < N)
list[i++] = in.nextInt();
int[] result = getMaxSubSum(list, N);
System.out.println(result[0] + " " + result[1] + " " + result[2]);
}
}
}