【字典樹】POJ_3283_Card Hands

Card Hands
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2853 Accepted: 881

Description
Jim is writing a program for statistically analyzing card games. He needs to store many different card hands in memory efficiently. Each card has one of four suits and one of thirteen values. In his implementation, each hand is stored as a linked list of cards in a canonical order: the cards are first ordered by suit: all the clubs come first, followed by all the diamonds, then all the hearts, and finally the spades. Within each suit, the cards are ordered by value: A, 2, 3, 4, 5, 6, 7, 8, 9, 10, J, Q, K. Each hand contains at most one of any given card.
The card hands are using lots of memory. Jim therefore decides to try a more efficient representation. Whenever any two lists share a common tail, they can be updated to share one copy of the tail, and the other copy can be discarded. This process can be repeated until no two lists share a common tail.
Your job is to tell Jim how many linked list nodes he needs to store all the card hands.

Input
The input contains several test cases followed by a line containing 0. The first line of each case contains the number of card hands. Each subsequent line describes a card hand. It starts with a number indicating the number of cards in the hand. The cards follow, separated by spaces, in the canonical order defined above. For each card, the value is given first, followed by the suit (C, D, H, or S). There are at most 100,000 cards in all hands.

Output
For each test case, output a line containing the number of linked list nodes needed to store all the lists.

Sample Input
3
3 7D AH 5S
4 9C 3D 4D 5S
2 AH 5S
0

Sample Output
6

Source
Waterloo Local Contest, 2006.5.27

題意:
給n個套卡牌(撲克52張),每一套有m張,每一套牌從尾到頭指向,形成一顆樹,求這顆樹有多少節(jié)點。

思路:
字典樹。

#include<cstdio>
#include<cstring>
#include<string>
#include<map>
using namespace std;

map<string, int> poker;

void init() {
    poker["AC"] = 0; poker["2C"] = 1; poker["3C"] = 2; poker["4C"] = 3; poker["5C"] = 4;
    poker["6C"] = 5; poker["7C"] = 6; poker["8C"] = 7; poker["9C"] = 8; poker["10C"] = 9; 
    poker["JC"] = 10; poker["QC"] = 11; poker["KC"] = 12;
    poker["AD"] = 13; poker["2D"] = 14; poker["3D"] = 15; poker["4D"] = 16; poker["5D"] = 17;
    poker["6D"] = 18; poker["7D"] = 19; poker["8D"] = 20; poker["9D"] = 21; poker["10D"] = 22;
    poker["JD"] = 23; poker["QD"] = 24; poker["KD"] = 25;
    poker["AH"] = 26; poker["2H"] = 27; poker["3H"] = 28; poker["4H"] = 29; poker["5H"] = 30;
    poker["6H"] = 31; poker["7H"] = 32; poker["8H"] = 33; poker["9H"] = 34; poker["10H"] = 35;
    poker["JH"] = 36; poker["QH"] = 37; poker["KH"] = 38;
    poker["AS"] = 39; poker["2S"] = 40; poker["3S"] = 41; poker["4S"] = 42; poker["5S"] = 43;
    poker["6S"] = 44; poker["7S"] = 45; poker["8S"] = 46; poker["9S"] = 47; poker["10S"] = 48;
    poker["JS"] = 49; poker["QS"] = 50; poker["KS"] = 51;
    return; 
}

const int maxn = 100000 + 10;
int cnt;
struct Node{
    int next[52];
}node[maxn];

int n, m;
char pok[maxn][5];

int build(int root, int val) {
    if (node[root].next[val] == 0)
        node[root].next[val] = cnt++;
    return node[root].next[val];
}

int main() {
    init();
    while (scanf("%d", &n) != EOF && n) {
        memset(node, 0, sizeof(node));
        cnt = 2;
        int root;
        for (int i = 0; i < n; ++i) {
            scanf("%d", &m);
            for (int j = 0; j < m; ++j) {
                scanf("%s", pok[j]);
            }
            root = build(1, poker[pok[m - 1]]);
            for (int j = m - 2; j >= 0; --j)
                root = build(root, poker[pok[j]]);
        }
        printf("%d\n", cnt - 2);
    }
    return 0;
}
最后編輯于
?著作權(quán)歸作者所有,轉(zhuǎn)載或內(nèi)容合作請聯(lián)系作者
平臺聲明:文章內(nèi)容(如有圖片或視頻亦包括在內(nèi))由作者上傳并發(fā)布,文章內(nèi)容僅代表作者本人觀點,簡書系信息發(fā)布平臺,僅提供信息存儲服務(wù)。
  • 序言:七十年代末,一起剝皮案震驚了整個濱河市,隨后出現(xiàn)的幾起案子,更是在濱河造成了極大的恐慌,老刑警劉巖,帶你破解...
    沈念sama閱讀 230,527評論 6 544
  • 序言:濱河連續(xù)發(fā)生了三起死亡事件,死亡現(xiàn)場離奇詭異,居然都是意外死亡,警方通過查閱死者的電腦和手機,發(fā)現(xiàn)死者居然都...
    沈念sama閱讀 99,687評論 3 429
  • 文/潘曉璐 我一進店門,熙熙樓的掌柜王于貴愁眉苦臉地迎上來,“玉大人,你說我怎么就攤上這事。” “怎么了?”我有些...
    開封第一講書人閱讀 178,640評論 0 383
  • 文/不壞的土叔 我叫張陵,是天一觀的道長。 經(jīng)常有香客問我,道長,這世上最難降的妖魔是什么? 我笑而不...
    開封第一講書人閱讀 63,957評論 1 318
  • 正文 為了忘掉前任,我火速辦了婚禮,結(jié)果婚禮上,老公的妹妹穿的比我還像新娘。我一直安慰自己,他們只是感情好,可當(dāng)我...
    茶點故事閱讀 72,682評論 6 413
  • 文/花漫 我一把揭開白布。 她就那樣靜靜地躺著,像睡著了一般。 火紅的嫁衣襯著肌膚如雪。 梳的紋絲不亂的頭發(fā)上,一...
    開封第一講書人閱讀 56,011評論 1 329
  • 那天,我揣著相機與錄音,去河邊找鬼。 笑死,一個胖子當(dāng)著我的面吹牛,可吹牛的內(nèi)容都是我干的。 我是一名探鬼主播,決...
    沈念sama閱讀 44,009評論 3 449
  • 文/蒼蘭香墨 我猛地睜開眼,長吁一口氣:“原來是場噩夢啊……” “哼!你這毒婦竟也來了?” 一聲冷哼從身側(cè)響起,我...
    開封第一講書人閱讀 43,183評論 0 290
  • 序言:老撾萬榮一對情侶失蹤,失蹤者是張志新(化名)和其女友劉穎,沒想到半個月后,有當(dāng)?shù)厝嗽跇淞掷锇l(fā)現(xiàn)了一具尸體,經(jīng)...
    沈念sama閱讀 49,714評論 1 336
  • 正文 獨居荒郊野嶺守林人離奇死亡,尸身上長有42處帶血的膿包…… 初始之章·張勛 以下內(nèi)容為張勛視角 年9月15日...
    茶點故事閱讀 41,435評論 3 359
  • 正文 我和宋清朗相戀三年,在試婚紗的時候發(fā)現(xiàn)自己被綠了。 大學(xué)時的朋友給我發(fā)了我未婚夫和他白月光在一起吃飯的照片。...
    茶點故事閱讀 43,665評論 1 374
  • 序言:一個原本活蹦亂跳的男人離奇死亡,死狀恐怖,靈堂內(nèi)的尸體忽然破棺而出,到底是詐尸還是另有隱情,我是刑警寧澤,帶...
    沈念sama閱讀 39,148評論 5 365
  • 正文 年R本政府宣布,位于F島的核電站,受9級特大地震影響,放射性物質(zhì)發(fā)生泄漏。R本人自食惡果不足惜,卻給世界環(huán)境...
    茶點故事閱讀 44,838評論 3 350
  • 文/蒙蒙 一、第九天 我趴在偏房一處隱蔽的房頂上張望。 院中可真熱鬧,春花似錦、人聲如沸。這莊子的主人今日做“春日...
    開封第一講書人閱讀 35,251評論 0 28
  • 文/蒼蘭香墨 我抬頭看了看天上的太陽。三九已至,卻和暖如春,著一層夾襖步出監(jiān)牢的瞬間,已是汗流浹背。 一陣腳步聲響...
    開封第一講書人閱讀 36,588評論 1 295
  • 我被黑心中介騙來泰國打工, 沒想到剛下飛機就差點兒被人妖公主榨干…… 1. 我叫王不留,地道東北人。 一個月前我還...
    沈念sama閱讀 52,379評論 3 400
  • 正文 我出身青樓,卻偏偏與公主長得像,于是被迫代替她去往敵國和親。 傳聞我的和親對象是個殘疾皇子,可洞房花燭夜當(dāng)晚...
    茶點故事閱讀 48,627評論 2 380

推薦閱讀更多精彩內(nèi)容