PAT-A 1012. The Best Rank (25)

傳送門

https://www.patest.cn/contests/pat-a-practise/1012

題目

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID|C|M|E|A
-|-|-|-|-
310101|98|85|88|90
310102|70|95|88|84
310103|82|87|94|88
310104|91|91|91|91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.
Output
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".
Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A

分析

先理解本題題意:
本題要求的是學生的最佳排名,怎么叫最佳排名呢?例如:C排第3,M排第1,那么輸出的就是1 M,如果有并列情況,按照A > C > M > E的優先級處理。

因為studentId和排名,以及studentId和課程,滿足key-value關系,所以這里選用map來解題。若使用數組的話,太耗費空間。

開始先定義結構體數組,存儲studentId和各類課程成績以及總分(平均分也可以),然后讀入數據。
接著,按照A > C > M > E的順序為結構體數組排序,要單獨寫4個排序函數,每次排序后遍歷數組,若排名比之前科目的排名靠前,則將數組的下標作為排名放到map里面,更新排名。(這里會出現問題,后面會詳細說)
最后,按照輸入的studentId,從map里面取出最佳排名和對應課程名輸出即可,若未找到改學生,則輸出N/A。

遇到的問題:
要考慮到學生成績相同的情況,也就是并列排名時,學生的排名應為:
1 2 3 3 5,而不是:1 2 3 4 5。如果單純用數組的下標作為排名的話會出現問題,我想到的解決方法是引入兩個變量,用來計算當前排名以及當前分數。
若后面學生分數和前面學生分數一致(即后面學生分數 = 當前分數),則后面學生的排名也要和前面學生排名保持一致(即后面學生排名 = 當前學生排名)。
若不一致,則更新當前的排名 = 數組下標,更新當前的分數 = 學生分數。

源代碼

//C/C++實現
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <map>

using namespace std;

struct student{
    int id;
    int C;
    int M;
    int E;
    int sum;
};

bool sortByA(const student& a, const student& b){
    return a.sum > b.sum;
}

bool sortByC(const student& a, const student& b){
    return a.C > b.C;
}

bool sortByM(const student& a, const student& b){
    return a.M > b.M;
}

bool sortByE(const student& a, const student& b){
    return a.E > b.E;
}

int main(){
    int n, m;
    scanf("%d %d", &n, &m);
    vector<student> v;
    for(int i = 0; i < n; ++i){
        student s;
        cin >> s.id >> s.C >> s.M >> s.E;
        s.sum = s.C + s.M + s.E;
        v.push_back(s);
    }
    map<int, int> mRank;
    map<int, char> mCourse;
    int currentRank, currentScore;
    //sort by A(sum)
    sort(v.begin(), v.end(), sortByA);
    currentRank = -1, currentScore = -1;
    for(int i = 0; i < v.size(); ++i){
        if(v[i].sum != currentScore){
            currentRank = i + 1;
        }
        mRank[v[i].id] = currentRank;
        mCourse[v[i].id] = 'A';
        currentScore = v[i].sum;
    }
    //sort by C
    sort(v.begin(), v.end(), sortByC);
    currentRank = -1, currentScore = -1;
    for(int i = 0; i < v.size(); ++i){
        if(v[i].C != currentScore){
            currentRank = i + 1;
        }
        if(currentRank < mRank[v[i].id]){
            mRank[v[i].id] = currentRank;
            mCourse[v[i].id] = 'C';
        }
        currentScore = v[i].C;
    }
    //sort by M
    sort(v.begin(), v.end(), sortByM);
    currentRank = -1, currentScore = -1;
    for(int i = 0; i < v.size(); ++i){
        if(v[i].M != currentScore){
            currentRank = i + 1;
        }
        if(currentRank < mRank[v[i].id]){
            mRank[v[i].id] = currentRank;
            mCourse[v[i].id] = 'M';
        }
        currentScore = v[i].M;
    }
    //sort by E
    sort(v.begin(), v.end(), sortByE);
    currentRank = -1, currentScore = -1;
    for(int i = 0; i < v.size(); ++i){
        if(v[i].E != currentScore){
            currentRank = i + 1;
        }
        if(currentRank < mRank[v[i].id]){
            mRank[v[i].id] = i + 1;
            mCourse[v[i].id] = 'E';
        }
        currentScore = v[i].E;
    }
    //output
    int tmp;
    for(int i = 0; i < m; ++i){
        scanf("%d", &tmp);
        if(mRank.count(tmp)){
            printf("%d %c\n", mRank[tmp], mCourse[tmp]);
        }
        else{
            printf("N/A\n");
        }
    }
    return 0;
}
最后編輯于
?著作權歸作者所有,轉載或內容合作請聯系作者
平臺聲明:文章內容(如有圖片或視頻亦包括在內)由作者上傳并發布,文章內容僅代表作者本人觀點,簡書系信息發布平臺,僅提供信息存儲服務。
  • 序言:七十年代末,一起剝皮案震驚了整個濱河市,隨后出現的幾起案子,更是在濱河造成了極大的恐慌,老刑警劉巖,帶你破解...
    沈念sama閱讀 229,908評論 6 541
  • 序言:濱河連續發生了三起死亡事件,死亡現場離奇詭異,居然都是意外死亡,警方通過查閱死者的電腦和手機,發現死者居然都...
    沈念sama閱讀 99,324評論 3 429
  • 文/潘曉璐 我一進店門,熙熙樓的掌柜王于貴愁眉苦臉地迎上來,“玉大人,你說我怎么就攤上這事。” “怎么了?”我有些...
    開封第一講書人閱讀 178,018評論 0 383
  • 文/不壞的土叔 我叫張陵,是天一觀的道長。 經常有香客問我,道長,這世上最難降的妖魔是什么? 我笑而不...
    開封第一講書人閱讀 63,675評論 1 317
  • 正文 為了忘掉前任,我火速辦了婚禮,結果婚禮上,老公的妹妹穿的比我還像新娘。我一直安慰自己,他們只是感情好,可當我...
    茶點故事閱讀 72,417評論 6 412
  • 文/花漫 我一把揭開白布。 她就那樣靜靜地躺著,像睡著了一般。 火紅的嫁衣襯著肌膚如雪。 梳的紋絲不亂的頭發上,一...
    開封第一講書人閱讀 55,783評論 1 329
  • 那天,我揣著相機與錄音,去河邊找鬼。 笑死,一個胖子當著我的面吹牛,可吹牛的內容都是我干的。 我是一名探鬼主播,決...
    沈念sama閱讀 43,779評論 3 446
  • 文/蒼蘭香墨 我猛地睜開眼,長吁一口氣:“原來是場噩夢啊……” “哼!你這毒婦竟也來了?” 一聲冷哼從身側響起,我...
    開封第一講書人閱讀 42,960評論 0 290
  • 序言:老撾萬榮一對情侶失蹤,失蹤者是張志新(化名)和其女友劉穎,沒想到半個月后,有當地人在樹林里發現了一具尸體,經...
    沈念sama閱讀 49,522評論 1 335
  • 正文 獨居荒郊野嶺守林人離奇死亡,尸身上長有42處帶血的膿包…… 初始之章·張勛 以下內容為張勛視角 年9月15日...
    茶點故事閱讀 41,267評論 3 358
  • 正文 我和宋清朗相戀三年,在試婚紗的時候發現自己被綠了。 大學時的朋友給我發了我未婚夫和他白月光在一起吃飯的照片。...
    茶點故事閱讀 43,471評論 1 374
  • 序言:一個原本活蹦亂跳的男人離奇死亡,死狀恐怖,靈堂內的尸體忽然破棺而出,到底是詐尸還是另有隱情,我是刑警寧澤,帶...
    沈念sama閱讀 39,009評論 5 363
  • 正文 年R本政府宣布,位于F島的核電站,受9級特大地震影響,放射性物質發生泄漏。R本人自食惡果不足惜,卻給世界環境...
    茶點故事閱讀 44,698評論 3 348
  • 文/蒙蒙 一、第九天 我趴在偏房一處隱蔽的房頂上張望。 院中可真熱鬧,春花似錦、人聲如沸。這莊子的主人今日做“春日...
    開封第一講書人閱讀 35,099評論 0 28
  • 文/蒼蘭香墨 我抬頭看了看天上的太陽。三九已至,卻和暖如春,著一層夾襖步出監牢的瞬間,已是汗流浹背。 一陣腳步聲響...
    開封第一講書人閱讀 36,386評論 1 294
  • 我被黑心中介騙來泰國打工, 沒想到剛下飛機就差點兒被人妖公主榨干…… 1. 我叫王不留,地道東北人。 一個月前我還...
    沈念sama閱讀 52,204評論 3 398
  • 正文 我出身青樓,卻偏偏與公主長得像,于是被迫代替她去往敵國和親。 傳聞我的和親對象是個殘疾皇子,可洞房花燭夜當晚...
    茶點故事閱讀 48,436評論 2 378

推薦閱讀更多精彩內容