G - Max Sum
HDU - 1003
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
題意:找到和最大的子序列,輸出和以及首位元素的位置。
解法:對于一個數(shù)有兩種選擇,加入前邊的序列,或者令起一個序列,即如果前邊序列和加上這個數(shù)之后仍比這個數(shù)小,那么從這個數(shù)開始令起一個序列。所以題目可以轉(zhuǎn)化成求各個局部的最大值,再在這些最大值里找最大值。
代碼:
#include<iostream>
using namespace std;
int a[100005];
int main()
{
int num;
cin>>num;
for(int k=1;k<=num;k++){
int n;
cin>>n;
for(int i=1;i<=n;i++)
cin>>a[i];
int sum=a[1];
int ans=a[1];
int x=1,y=1,z=1;
for(int i=2;i<=n;i++){
if(a[i]>sum+a[i]){
sum=a[i];
z=i;
}
else
sum+=a[i];
if(sum>ans){
ans=sum;
x=z;
y=i;
}
}
cout<<"Case "<<k<<":"<<endl;
cout<<ans<<" "<<x<<" "<<y<<endl;
if(k!=num)
cout<<endl;
}
return 0;
}